New YaCy install will not accept new admin password

Install was a breeze, but then I run:

./bin/ passwordhere

I get notification that the password for the user ‘admin’ has changed, but I can not log in with it.

This was a brand new install on a public facing server and now I can not access the YaCy admin area to configure the install how I want it.

I have stopped and restarted YaCy as well, I have changed the password to “password” temporarily to remove any special characters. Nothing seems to take hold to allow me to access the admin area with the credentials I supply.

Any advice?

EDIT: I have searched and no solution seems to help. This is installed on a Ubuntu 20 Server.

I have tried this method to change it manually via the .conf file and still not working Forgot your password

yes, its a bug … I will post a solution soon

Thanks. I got in by just creating an ssh-tunnel to force localhost:8090 to resolve to the remote server and I was able to get in and setup a password from the admin area.

But so far that is the only issue I’ve had. I’m having fun learning the software and look forward to actually putting into production at some point in the future.

1 Like

I have fixed it. You can grab it from the souce repo if you want to compile YaCy yourself (see but I will make a hotfix release probably in the next days

I have the same problem. It is 3 month later. Is there any fix available now (without compiling it by myself)

I installed folowing the instructions on Download - YaCy with the exception that I installed openjdk-11-jre-headless because 8 is not available (I guess it should be changed in the instructions)

Please try
I just compiled it as the latest solr-6.6 based version. It should have the password fix inside.